duminică, 5 februarie 2017

Testing Unity 3D with Fedora 25 start with some bugs.

Today I will tested the Unity 3D with Fedora 25.
The hardware I used is:
video: # lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
 
cpu: # lscpu Architecture: x86_64 CPU op-mode(s): 32-bit, 64-bit Byte Order: Little Endian CPU(s): 4 On-line CPU(s) list: 0-3 Thread(s) per core: 1 Core(s) per socket: 4 Socket(s): 1 NUMA node(s): 1 Vendor ID: GenuineIntel CPU family: 6 Model: 60 Model name: Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz Stepping: 3 CPU MHz: 2943.750 CPU max MHz: 3400.0000 CPU min MHz: 800.0000 BogoMIPS: 6385.65 Virtualization: VT-x L1d cache: 32K L1i cache: 32K L2 cache: 256K L3 cache: 6144K NUMA node0 CPU(s): 0-3 Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts
The install can be used into root account:
[mythcat@localhost Downloads]$ sh unity-editor-installer-5.1.0f3+2015082501.sh This installer must be run as root. [mythcat@localhost Downloads]$ su Password: [root@localhost Downloads]# sh unity-editor-installer-5.1.0f3+2015082501.sh Installer for Unity 5.1.0f3 Press Enter to begin extracting to ./unity-editor-5.1.0f3 Unpacking Unity 5.1.0f3 ... 
Extraction complete. Run ./unity-editor-5.1.0f3/Editor/Unity to begin
First start of Unity come with this error:
$ ./unity-editor-5.1.0f3/Editor/Unity ./unity-editor-5.1.0f3/Editor/Unity: /home/mythcat/Downloads/unity-editor-5.1.0f3/Editor/Data/Tools/libgpg-error.so.0: no version information available (required by /lib64/libgcrypt.so.20) ./unity-editor-5.1.0f3/Editor/Unity: relocation error: /lib64/libgcrypt.so.20: symbol gpg_err_set_errno, version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference
I need to remove libgpg-error.so.0 file the from this folder:
rm /home/mythcat/Downloads/unity-editor-5.1.0f3/Editor/Data/Tools
After that the Unity Editor start well but another error come into default Unity scene.
Errors and problems I found:
- the new material cannot be added to the 3D object by drag and drop;
- the skybox come with a pink color without the sky I know from Windows OS (maybe some problems come from video: Shader compiler: internal error compiling shader snippet type=1 platform=0: Error reading external process - read 0 bytes and this Shader compiler: internal error compiling shader snippet type=1 platform=0: Error reading external process - read 0 bytes);
- the open C# script not work;
I make a Unity application - default scene and worked well.
I make a bug report here.
You can download the Unity sh file from here.

Niciun comentariu:

Trimiteți un comentariu