joi, 11 iunie 2015

Fix Bash shell vulnerability under Linux OS .

If some Bash code outside of the curly brace then it will then be executed by the linux system.
env x='() { :;}; echo vulnerable' bash -c " bash test "
If your system is vulnerable, it will then output:
vulnerable
bash test 
How Do You Fix It ? Just open up a terminal, and type:
sudo apt-get update
sudo apt-get upgrade
or under Fedora with :
sudo yum update
Also you can see more about linux and linux tutorials here.

Niciun comentariu:

Trimiteți un comentariu