miercuri, 29 decembrie 2010

Nokia SDK and MIDlet

Yesterday I played with the SDK from Nokia. Do you think that it's easy to create a MIDlet . Finally I managed to make an application "Helllo World'.
Maybe I'll write a little tutorial in the near future when I'll know more about MIDlets and java.
Here is the resulting feedback.

duminică, 12 decembrie 2010

Blender 3D and F14 killed by "Save as"

Although he reached the 2.55 beta, Fedora 14 is still struggling with version 2.49b.
Not bad if it goes, but here's one little problem
It's all well and good until the "Save as".
Then it breaks and you have just this reason:
Process /usr/bin/blender.bin was killed by signal 6 (SIGABRT)

vineri, 10 decembrie 2010

Christmas - new decor script for your desktop .

Last year I made a python scrip to beautify your desktop on Christmas Day.
I wrote it here about this script.
I lost the script , but now  I wrote this script again.
The script is very simple and you can get it here.
Here's what makes this script:

joi, 9 decembrie 2010

gDEBugger - FREE or NOT ?

A very popular OpenGL debugger is now available for FREE?
On official site we saw:
Order
gDEBugger is not available for purchasing for the time being.
We plan to release a new and **FREE** gDEBugger version for Windows, Linux and Mac OS X. This version will be available for download by the end of 2010.
Please make sure to check our website for this version in the near future.
Until the free version will be released, please find below a temporary license file that will enable you to use the current gDEBugger version for free immediately.

Now is the end of 2010 , but is not free.
What is gDEBugger
Named gDEBugger is an advanced OpenGL Debugger, Profiler and Graphic Memory Analyzer.
This 3D software saves you debugging time and helps you boost application performance.
We can download it from :here.
I searchon my computer the lib libstdc++, see below :
# yum search libstdc++
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
============================== Matched: libstdc++ ==============================
compat-libstdc++-296.i686 : Compatibility 2.96-RH standard C++ libraries
compat-libstdc++-33.i686 : Compatibility standard C++ libraries
libstdc++.i686 : GNU Standard C++ Library
libstdc++-devel.i686 : Header files and libraries for C++ development
libstdc++-docs.i686 : Documentation for the GNU standard C++ library
libstdc++-static.i686 : Static libraries for the GNU standard C++ library
The archive named gDEBugger57-i386-cpp3.tar.gz has 13Mb.
Then i use commands :

$gzip -dc gDEBugger57-i386-cpp3.tar.gz | tar xf -
$ cd gDEBugger57-i386-cpp3
$ su 
# yum install compat-libstdc++-33.i686 
The gDEBugger run well under fedora 14 , but is free only 7 days. See bellow:

miercuri, 8 decembrie 2010

Fakeroot and Yum

It seems that the "yum" and "fakeroot" do not get along too well. I did not understand why ... Here is output:
yum search aaa
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Cannot open logfile /var/log/yum.log
Could not create lock at /var/run/yum.pid: [Errno 13] Permission denied: '/var/run/yum.pid'
Another app is currently holding the yum lock; waiting for it to exit...
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 258, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 104, in main
    show_lock_owner(e.pid, logger)
  File "/usr/share/yum-cli/utils.py", line 107, in show_lock_owner
    ps = get_process_info(pid)
  File "/usr/share/yum-cli/utils.py", line 62, in get_process_info
    if (not os.path.exists("/proc/%d/status" % pid) or
TypeError: %d format: a number is required, not str
 

And I have nothing on,like rpm , yum or gpk-prefs...

sâmbătă, 4 decembrie 2010

Fedora 14 and NVIDIA FX5200

Today i set video driver on Fedora 14.
I have a FX5200 and i use akmod to make this working .
First when i install akmod with :
yum install kmod-nvidia-173xx-2.6.35.6-48.fc14.i686.PAE.i686
I have some errors:
$ glxinfo | grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
But i solve and Savage XR working well :

joi, 2 decembrie 2010

Fedora 14 versus 3D software .

In the next few days ago I decided to try software 3d with Fedora 14.
I am disappointed again. I was expecting some improvements in this area by the developers.
Especially because it is a difficult topic.
But let's see why I have this impression...
I have searched for packages that are required with this command:
# yum search "3d engine"
...
============================== Matched: 3d engine ==============================
irrlicht.i686 : A high performance realtime 3D engine
crystalspace.i686 : Crystal Space a free 3D engine
ember.i686 : 3D client for WorldForge
ogre.i686 : Object-Oriented Graphics Rendering Engine
Code:: Blocks does not work with Ogre 3D or Irrlicht 3D packages. Although I spent quite a long time. However on Windows XP this combination worked well.
Ember game working hard. Maybe because my video card - FX5200, not really likes the new drivers.
Code:: Blocks is very stubborn. Ogre and Irrlicht Wizards of the Linux version of Code:: Blocks does not work at all.